26 lines
934 B
Bash
Executable file
26 lines
934 B
Bash
Executable file
#!/bin/bash
|
|
|
|
set -u
|
|
set -o pipefail
|
|
|
|
[ "$1" = binary ] || exit 0
|
|
|
|
./generate_testcases.sh | xargs --max-args=8 ./check.sh 2>../buildlog.txt | tee ../results.txt
|
|
|
|
if [ $? -ne 0 ]; then
|
|
echo "Generating the testcases failed. The last 10 lines from the stderr log are:"
|
|
tail --lines=10 ../buildlog.txt
|
|
exit 1
|
|
fi
|
|
|
|
num_results=$(wc -l < ../results.txt)
|
|
echo "Num-Testcases: $num_results"
|
|
echo "Perc-All-Agree: $(echo "scale=2;$(grep -E ' 0 0 0$| 1 1 1$' ../results.txt | wc -l)*100/$num_results" | bc) %"
|
|
echo "Perc-Dose-Apt-Agree: $(echo "scale=2;$(grep -E ' 0 0 .$| 1 1 .$' ../results.txt | wc -l)*100/$num_results" | bc) %"
|
|
echo "Perc-Dose-Dpkg-Agree: $(echo "scale=2;$(grep -E ' 0 . 0$| 1 . 1$' ../results.txt | wc -l)*100/$num_results" | bc) %"
|
|
echo "Perc-Apt-Dpkg-Agree: $(echo "scale=2;$(grep -E ' . 0 0$| . 1 1$' ../results.txt | wc -l)*100/$num_results" | bc) %"
|
|
|
|
cat << END > debian/files
|
|
buildlog.txt - -
|
|
results.txt - -
|
|
END
|