You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

66 lines
1.5 KiB
Diff

Index: python-ijon-0.4/Makefile
===================================================================
--- python-ijon-0.4.orig/Makefile 2010-08-25 11:05:14.000000000 +0000
+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
@@ -1,60 +0,0 @@
-#!/usr/bin/env make -f
-#HOST=murphy
-#HOST=gta01
-HOST=gta02
-EPATH=/opt/e17
-
-.PHONY: all
-all:
- PATH=$(PATH):$(EPATH)/bin \
- LD_LIBRARY_PATH=$(EPATH)/lib \
- PYTHONPATH=$(EPATH)/lib/python2.5/site-packages:src \
- ./setup.py bdist
-
-.PHONY: run
-run:
- LD_LIBRARY_PATH=$(EPATH)/lib \
- PYTHONPATH=$(EPATH)/lib/python2.5/site-packages:src \
- ./src/ijon/run.py data/ijon.ini
-
-.PHONY: dbg
-dbg: clean
- rsync --verbose --archive --delete ijon/. root@$(HOST):/usr/share/pyshared/ijon/.
-
-.PHONY: clean
-clean:
- for n in `cat ../.gitignore`; do \
- if echo $$n | grep -q /; then \
- rm -rfv "$$n"; \
- else \
- find . -name "$$n" | xargs rm -fv; \
- fi \
- done
-
-.PHONY: docs
-docs: docs/index.html
-
-docs/index.html: Makefile
- mkdir -p docs
- LD_LIBRARY_PATH=$(EPATH)/lib \
- PYTHONPATH=$(EPATH)/lib/python2.5/site-packages:src \
- epydoc \
- --css=data/epydoc.css \
- --debug \
- --docformat=restructuredtext \
- --graph=classtree \
- --graph-font-size=32 \
- --graph-font='Vera' \
- --html \
- --include-log \
- --name='ijon - documentation' \
- --navlink=Home \
- --no-imports \
- --no-private \
- --no-sourcecode \
- --output=docs \
- --quiet \
- --simple-term \
- --url=http://www.paroli-project.org/ \
- src/ijon/*.py
-